Skip to content Skip to main navigation Report an accessibility issue

OIT News

Is Your Zoom Client Up-to-Date?


Zoom will implement its new Software Lifecycle Policy on November 5th for all products and services. Users running a Zoom client older than version 5.8.6 will not be able to join meetings via the Zoom client and will be prompted to update or join from the web browser. We highly recommend you regularly check for updates and install the latest version of Zoom software.

To update the Zoom desktop application:

  1. Log in to the desktop application.
  2. Select the profile image at the top-right of the application window (this could be your initials or a profile picture that you have uploaded).
  3. Choose the option to Check for Updates and follow the prompts on the screen.

On October 1st, we will be implementing a minimum client version enforcement for all users. Once we enable this feature, you will be prompted to update to the specified version before you can sign in or start a meeting/webinar.